Тема: Ошибка на платформе 8.3.13.1513 при создании библ. записи

Ошибка на платформе 8.3.13.1513 при создании библ. записи Назад к темам
№10553
0
Пользователь

Сообщений: 1
Рейтинг пользователей: 0
Регистрация: 26.11.2018

1С: Предприятие 8.3 (8.3.13.1513)
1С:Библиотека, редакция 2.1 (2.1.8.1).

Здравствуйте.
Обновили платформу 1С:Предприятие 8.3 до версии 8.3.13.1513. При создании библ. записи (например, книги), при выделении элементов библиографической записи (список слева) для выбора значений из справочника (список справа) получаем ошибку:
«
{Обработка.РедакторБиблЗаписей.Форма.РедакторБиблЗаписиУпр.Форма(1937)}: Поле объекта не обнаружено (СписокСправочникКодЗначения)
СтрЭлементыФормы.Вставить("СписокСправочникКодЗначения",Элементы.СписокСправочникКодЗначения);
«

В результате нет возможности создать библиографическую запись. До этого была 8.3.10.2580, такой проблемы не было.

№10666
0
Партнер
Комплексные системы автоматизации
Сообщений: 2
Рейтинг пользователей: 0
Регистрация: 18.02.2019

Присоединяюсь к вопросу. Такая же ошибка, платформа 8.3.13.1690

№10667
0
Партнер
Комплексные системы автоматизации
Сообщений: 2
Рейтинг пользователей: 0
Регистрация: 18.02.2019

Костыльное решение. Может, кому пригодится.
Обработка РедакторБиблЗаписей, форма РедакторБиблЗаписиУпр. Процедуру ОбновитьСписокСправочник() излагаем в следующем виде:

&НаСервере
Процедура ОбновитьСписокСправочник(ВхПараметры)

стрПараметрыСправ = ОпределитьПараметрыСправочника(ВхПараметры);

СтрЭлементыФормы = Новый Структура;
СтрЭлементыФормы.Вставить("СписокСправочник",Элементы.СписокСправочник);
//++костыль
Если Элементы.Найти("СписокСправочникКодЗначения") = Неопределено Тогда
Элемент = Элементы.Добавить("СписокСправочникКодЗначения", Тип("ПолеФормы"), Элементы.СписокСправочник);
Элемент.Вид = ВидПоляФормы.ПолеВвода;
//Элемент.ПутьКДанным = "СписокСправочник.КодЗначения";
Элемент.Видимость = Истина;
Элемент.Доступность = Ложь;
Элемент.ТолькоПросмотр = Ложь;
Элемент.КнопкаОчистки = Ложь;
КонецЕсли;
//--костыль
СтрЭлементыФормы.Вставить("СписокСправочникКодЗначения",Элементы.СписокСправочникКодЗначения);
СтрЭлементыФормы.Вставить("СписокСправочникУстановитьОтборПоИспЗначения",Элементы.СписокСправочникУстановитьОтборПоИспЗначения);
СтрЭлементыФормы.Вставить("СписокСправочникПометитьНаУдалениеЭлементСправочника",Элементы.СписокСправочникПометитьНаУдалениеЭлементСправочника);
//СтрЭлементыФормы.Вставить("СписокСправочник_ВыбранныеЗначения",Элементы.СписокСправочник_ВыбранныеЗначения);
//СтрЭлементыФормы.Вставить("ГруппаСправочник",Элементы.ГруппаСправочник);
СтрЭлементыФормы.Вставить("СоздатьЭлементСправочника",Элементы.СоздатьЭлементСправочника);
СтрЭлементыФормы.Вставить("СоздатьГруппуСправочника",Элементы.СоздатьГруппуСправочника);

РедакторБиблЗаписейСервер.ОбновитьСписокСправочник(стрПараметрыСправ,СписокСправочник,СтрЭлементыФормы);

//++костыль
Если Найти(СписокСправочник.ТекстЗапроса, "КодЗначения") > 0 Тогда
Элемент = Элементы.СписокСправочникКодЗначения;
Если Не ЗначениеЗаполнено(Элемент.ПутьКДанным) Тогда
Элемент.ПутьКДанным = "СписокСправочник.КодЗначения";
КонецЕсли;
КонецЕсли;
//--костыль

КонецПроцедуры